Pytorch does not currently provide packages for PyPI


RuntimeError: PyTorch does not currently provide packages for PyPI (see status at pytorch/pytorch#566).

Please follow the instructions at to install with miniconda instead.

Command "python egg_info" failed with error code 1 in /tmp/pip-build-nuat_xgu/torch/


Install Pytorch first

If you continue to see the same error, make install

We should also update this information (i.e. installing Pytorch first) on the project homepage - How to Install instructions.

1 Like

Hi, thank you for this note. I think the current documentation is still missing this information, which is important especially if the user already has a PyTorch installed in the environment that pyro is being installed on.

What happened to me today is the following:
I have an environment with PyTorch set up via conda install -c pytorch pytorch as instructed in the official guideline from Pytorch. I also had Pyro setup (half a year ago) and I had forgotten that I installed pyro using the source, and not the pip install. Because the conda list | grep pyro still showed that pyro was installed from pypi and because it was awhile ago that I installed pyro-ppl, I thought it would be safe to upgrade pyro using pip install --upgrade. So I ran pip install --upgrade pyro-ppl, but unfortunately the command resulted in force-deleting the existing PyTorch from pytorch channel and install one from pypi. No agreement was asked whether I approve this deletion and reinstallation of PyTorch.

This removal and reinstallation of Pytorch from pypi when I upgraded pyro-ppl made me concerned whether pyro library properly links pytorch library if the only pytorch library in the environment is not installed from pypi, but from a different channel like pytorch, which is what we get from manually installing it from a conda command as above.

Since I need to use torch library from pytorch channel for compatibility with other closely related libraries as well as the cuda compatibility, I installed pytorch again, using the same conda command as above. So, now I have both pytorch and torch as below:

If I delete torch (installed during pyro-ppl upgrade), will pyro library correctly link the codes from pytorch library? As Iā€™m hoping to use neural net models implemented in pytorch, I really hope there is no mismatch in the version of PyTorch library that pyro uses and the model I implement (in PyTorch).

Hope my question makes sense, and please let me know if you need any clarification.
Thank you!