Numpyro and arviz version numbers?

Hi all, we are trying to use arviz with the latest numpyro, in Google Colab.
We installed using pip3 install numpyro and pip3 install arviz.

When calling az.from_numpyro(mcmc), right after calling, **data),
we get the following error message:
ContextualVersionConflict: (jaxlib 0.1.66+cuda110 (/usr/local/lib/python3.7/dist-packages), Requirement.parse(‘jaxlib==0.1.62’), {‘numpyro’})

We tried to downgrade our versions of numpyro (we also tried to downgrad jax, jaxlib), however we get similar error messages.

Our current version numbers are:
jaxlib = 0.1.62
jax = 0.2.10
numpyro = 0.6.0
arviz = 0.11.2

We would like to use the latest numpyro version, with arviz, in Google Colab. Could this be an issue with the versions in Google Colab?
Would you have suggestions on how to fix this?
Would you have a known set of version numbers that would work, in Google Colab? thank you!

Could you run this tutorial in colab? I don’t see that error when using arviz.

1 Like

yes, thank you @fehiepsi ! :grin: that was very useful: after building the wheel for arviz, now it works.